Ubuntu18.04.2 Linux Receiving the error: snapd.snap-repair.service is a disabled or a static unit

it2022-05-06  4

我们在Ubuntu18.04.2 执行apt-get upgrade时候,报错:

正在设置 snapd (2.39.2+18.04) ... md5sum: /etc/apparmor.d/usr.lib.snapd.snap-confine: 没有那个文件或目录 snapd.failure.service is a disabled or a static unit, not starting it. snapd.snap-repair.service is a disabled or a static unit, not starting it.

解决方案如下:

sudo fuser -vki /var/lib/dpkg/lock sudo apt purge snapd sudo dpkg --configure -a sudo apt update sudo apt upgrade sudo apt dist-upgrade sudo apt install snapd

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

补充: 

sudo dpkg -r snapd gnome-software-plugin-snap sudo apt update sudo apt full-upgrade

 

解决方案来自:https://askubuntu.com/questions/1037431/receiving-the-error-snapd-snap-repair-service-is-a-disabled-or-a-static-unit-n


最新回复(0)